blob: 4544f5b2ef03ff6519322635658358f5f2193cdf [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Shows and sets processor power related values"
2DESCRIPTION = "cpupower is a collection of tools to examine and tune power \
3saving related features of your processor."
4LICENSE = "GPLv2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006DEPENDS = "pciutils gettext-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007PROVIDES = "virtual/cpupower"
8
9inherit kernelsrc kernel-arch
10
11do_populate_lic[depends] += "virtual/kernel:do_patch"
12
13EXTRA_OEMAKE = "-C ${S}/tools/power/cpupower O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
14
15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16
17do_compile() {
18 oe_runmake
19}
20
21do_install() {
22 oe_runmake DESTDIR=${D} install
23 # Do not ship headers
24 rm -rf ${D}${includedir}
25 chown -R root:root ${D}
26}
27
28PACKAGE_ARCH = "${MACHINE_ARCH}"
29
30RDEPENDS_${PN} = "bash"
31
32python do_package_prepend() {
33 d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
34}
35
36B = "${WORKDIR}/${BPN}-${PV}"