blob: 629e2518f40b0fb3d5667c79f23796bf25747a6d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "VMcore extraction tool"
2DESCRIPTION = "\
3 This program is used to extract a subset of the memory available either \
4 via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \
5 images without extra uneeded information (zero pages, userspace programs, \
6 etc). \
7"
8HOMEPAGE = "http://makedumpfile.sourceforge.net"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11LICENSE = "GPLv2.0"
12
13DEPENDS = "bzip2 zlib elfutils"
14RDEPENDS_${PN}-tools = "perl ${PN}"
15
16# arm would compile but has never been tested upstream. mips would not compile.
17#
18COMPATIBLE_HOST = "(x86_64|i.86|powerpc|arm).*-linux"
19
20PACKAGES =+ "${PN}-tools"
21FILES_${PN}-tools = "${bindir}/*.pl"
22
23SRC_URI = "\
24 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \
25 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
26 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \
27"
28SRC_URI[md5sum] = "7dfbca19f487604c271e2892ba07f4bd"
29SRC_URI[sha256sum] = "7e06f72d5f291fcab9e92975f405a76e37d4f7fc8fa4172f199636398ae812b1"
30
31UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/makedumpfile/files/makedumpfile/"
32UPSTREAM_CHECK_REGEX = "makedumpfile/(?P<pver>\d+(\.\d+)+)/"
33
34SECTION = "base"
35
36# If we do not specify TARGET, makedumpfile will build for the host but use the
37# target gcc.
38#
39EXTRA_OEMAKE = "\
40 LINKTYPE=static \
41 TARGET=${TARGET_ARCH} \
42"
43
44do_install () {
45 mkdir -p ${D}/usr/bin
46 install -m 755 ${S}/makedumpfile ${D}/usr/bin
47 install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin
48
49 mkdir -p ${D}/usr/share/man/man8
50 install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8
51
52 mkdir -p ${D}/usr/share/man/man5
53 install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5
54
55 mkdir -p ${D}/etc/
56 install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample
57}