blob: dc3e78febb11991d1ad3498411aac4f5ac9b3987 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4# This program is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License version 2 as
6# published by the Free Software Foundation.
7#
8SUMMARY = "Frequency and Idle power monitoring tools for Linux"
9
10DESCRIPTION = "The turbostat tool allows you to determine the actual \
11processor frequency and idle power saving state residency on supported \
12processors."
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
16COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
17COMPATIBLE_HOST_libc-musl = "null"
18
19SRC_URI += "\
20 file://COPYING \
21 "
22
23DEPENDS = "virtual/kernel"
24
25# This looks in S, so we better make sure there's
26# something in the directory.
27#
28do_populate_lic[depends] = "${PN}:do_configure"
29
30
31EXTRA_OEMAKE = '\
32 CC="${CC}" \
33 'CFLAGS=-Wall -I${STAGING_KERNEL_DIR}/arch/x86/include/uapi ${LDFLAGS}' \
34 '
35
36# If we build under STAGING_KERNEL_DIR, source will not be put
37# into the dbg rpm. STAGING_KERNEL_DIR will exist by the time
38# do_configure() is invoked so we can safely copy from it.
39#
40do_configure_prepend() {
41 mkdir -p ${S}
42 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
43 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
44 cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
45 cp -r ${WORKDIR}/COPYING ${S}
46}
47
48do_compile() {
49 sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
50 sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
51 sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile
52 oe_runmake STAGING_KERNEL_DIR=${STAGING_KERNEL_DIR}
53}
54
55do_install() {
56 oe_runmake DESTDIR="${D}" install
57}