blob: 6c2176f79c19b42b7d0a81e5b5acee3c728ad772 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
2# The following is the difference between the old and the new license text.
3# Please update the LICENSE value if needed, and summarize the changes in
4# the commit message via 'License-Update:' tag.
5# (example: 'License-Update: copyright years updated.')
6#
7# The changes:
8#
9# --- COPYING
10# +++ COPYING
11# @@ -2,7 +2,8 @@
12# Version 2, June 1991
13#
14# Copyright (C) 1989, 1991 Free Software Foundation, Inc.
15# - 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
16# + 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
17# +
18# Everyone is permitted to copy and distribute verbatim copies
19# of this license document, but changing it is not allowed.
20#
21#
22#
23
24SUMMARY = "Alsa OSS Compatibility Package"
25SECTION = "libs/multimedia"
26LICENSE = "GPLv2"
27LIC_FILES_CHKSUM = "file://COPYING;md5=ed055b4eff93da784176a01582e6ec1a"
28DEPENDS = "alsa-lib"
29
30SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \
31 file://libio.patch \
32"
33SRC_URI[md5sum] = "fc845cafc4444193510ab1865c7350b8"
34SRC_URI[sha256sum] = "c3d3f743e61f05ff95c5cba3b06bc9c91ff86c37495f1d19dab844e6b90845ea"
35
36inherit autotools
37
38LEAD_SONAME = "libaoss.so.0"
39
40do_configure_prepend () {
41 touch NEWS README AUTHORS ChangeLog
42 sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in
43}
44
45# http://errors.yoctoproject.org/Errors/Details/186961/
46EXCLUDE_FROM_WORLD_libc-musl = "1"