blob: dd6789dc01165e793c23f4ca73ce87566754470b [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Opus Audio Codec"
2DESCRIPTION = "The Opus codec is designed for interactive \
3speech and audio transmission over the Internet. It is \
4designed by the IETF Codec Working Group and incorporates \
5technology from Skype's SILK codec and Xiph.Org's CELT codec."
6HOMEPAGE = "http://www.opus-codec.org/"
7SECTION = "libs/multimedia"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3"
10
11SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz"
12SRC_URI[md5sum] = "32bbb6b557fe1b6066adc0ae1f08b629"
13SRC_URI[sha256sum] = "58b6fe802e7e30182e95d0cde890c0ace40b6f125cffc50635f0ad2eef69b633"
14
15S = "${WORKDIR}/opus-${PV}"
16
17inherit autotools pkgconfig
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[fixed-point] = "--enable-fixed-point,,"
21PACKAGECONFIG[float-approx] = "--enable-float-approx,,"
22
23EXTRA_OECONF = " \
24 --with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \
25 --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \
26 --enable-asm \
27 --enable-intrinsics \
28 --enable-custom-modes \
29"
30
31python () {
32 if d.getVar('TARGET_FPU') in [ 'soft' ]:
33 d.appendVar('PACKAGECONFIG', ' fixed-point')
34
35 # Ne10 is only available for armv7 and aarch64
36 if any((t.startswith('armv7') or t.startswith('aarch64')) for t in d.getVar('TUNE_FEATURES').split()):
37 d.appendVar('DEPENDS', ' ne10')
38}
39
40# Fails to build with thumb-1 (qemuarm)
41#| {standard input}: Assembler messages:
42#| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4'
43#| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1'
44#| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0'
45#| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1'
46#| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1'
47#| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3'
48#| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10'
49#| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9'
50#| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8'
51#| make[2]: *** [celt/celt.lo] Error 1
52ARM_INSTRUCTION_SET = "arm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053
54BBCLASSEXTEND = "native nativesdk"