blob: 01be1515b7c0bc556c66e9669915311bb5a0597d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security"
4LICENSE = "GPL-2.0"
5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=1489288f46af415fadc4e8b6345ab9f4"
7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9 file://nmap-redefine-the-python-library-dir.patch \
10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
11"
12
13SRC_URI[md5sum] = "84eb6fbe788e0d4918c2b1e39421bf79"
14SRC_URI[sha256sum] = "847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18"
15
16inherit autotools-brokensep pkgconfig pythonnative
17
18PACKAGECONFIG ?= "ncat nping ndiff pcap"
19
20PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
21PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpre"
22PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
23PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
24PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
25
26#disable/enable packages
27PACKAGECONFIG[nping] = ",--without-nping,"
28PACKAGECONFIG[ncat] = ",--without-ncat,"
29PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
30PACKAGECONFIG[update] = ",--without-nmap-update,"
31
32EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
33
34# zenmap needs python-pygtk which has been removed
35# it also only works with python2
36# disable for now until py3 is supported
37EXTRA_OECONF += "--without-zenmap"
38
39export PYTHON_SITEPACKAGES_DIR
40
41do_configure() {
42 autoconf
43 oe_runconf
44}
45
46FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
47
48RDEPENDS_${PN} = "python"