blob: c171963c2fef005bc4b372156a4524931c3e4f67 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \
2 The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \
3 It includes all features of 4.4BSD C shell, plus a command-line editor, \
4 programmable word completion, spelling correction and more."
5
6HOMEPAGE = "http://www.tcsh.org/"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5"
9SECTION = "base"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010DEPENDS = "ncurses virtual/crypt gettext-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011SRC_URI = " \
12 http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/${BP}.tar.gz \
13 file://0001-Enable-system-malloc-on-all-linux.patch \
14 file://0002-Add-debian-csh-scripts.patch \
15"
16SRC_URI[md5sum] = "59d40ef40a68e790d95e182069431834"
17SRC_URI[sha256sum] = "b89de7064ab54dac454a266cfe5d8bf66940cb5ed048d0c30674ea62e7ecef9d"
18
19EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'"
20inherit autotools
21
22do_compile_prepend() {
23 oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost
24}
25
26do_install_append () {
27 oe_runmake install.man DESTDIR=${D}
28
29 install -d ${D}${base_bindir}
30 ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
31 ln -s /usr/bin/tcsh ${D}${base_bindir}/csh
32 install -d ${D}${sysconfdir}/csh/login.d
33 install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
34 install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
35}
36
37FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
38
39
40pkg_postinst_${PN} () {
41#!/bin/sh -e
42echo /usr/bin/tcsh >> $D/etc/shells
43echo /usr/bin/csh >> $D/etc/shells
44}