blob: 302813c2ea55e940d414f258c098d124c3b5c78f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Monitor for system resources and process activity"
2DESCRIPTION = "Atop is an ASCII full-screen performance monitor for Linux that \
3is capable of reporting the activity of all processes (even if processes have \
4finished during the interval), daily logging of system and process activity for \
5long-term analysis, highlighting overloaded system resources by using colors, \
6etc. At regular intervals, it shows system-level activity related to the CPU, \
7memory, swap, disks (including LVM) and network layers, and for every process \
8(and thread) it shows e.g. the CPU utilization, memory growth, disk \
9utilization, priority, username, state, and exit code."
10HOMEPAGE = "http://www.atoptool.nl"
11SECTION = "console/utils"
12
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
15
16DEPENDS = "ncurses zlib"
17
18SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \
20 file://remove-bashisms.patch \
21 file://fix-permissions.patch \
22 file://sysvinit-implement-status.patch \
23 file://0001-add-sys-sysmacros.h-for-major-minor-macros.patch \
24 "
25SRC_URI[md5sum] = "48e1dbef8c7d826e68829a8d5fc920fc"
26SRC_URI[sha256sum] = "73e4725de0bafac8c63b032e8479e2305e3962afbe977ec1abd45f9e104eb264"
27
28do_compile() {
29 oe_runmake all
30}
31
32do_install() {
33 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
34 make DESTDIR=${D} VERS=${PV} SYSDPATH=${systemd_system_unitdir} \
35 PMPATHD=${systemd_unitdir}/system-sleep systemdinstall
36 install -d ${D}${sysconfdir}/tmpfiles.d
37 install -m 644 ${WORKDIR}/volatiles.atop.conf ${D}${sysconfdir}/tmpfiles.d/atop.conf
38 rm -f ${D}${systemd_system_unitdir}/atopacct.service
39 else
40 make DESTDIR=${D} VERS=${PV} sysvinstall
41 install -d ${D}${sysconfdir}/default/volatiles
42 install -m 644 ${WORKDIR}/volatiles.99_atop ${D}${sysconfdir}/default/volatiles/99_atop
43 rm -f ${D}${sysconfdir}/init.d/atopacct
44 fi
45
46 # remove atopacct related files
47 rm -rf ${D}${sbindir} ${D}${mandir}/man8
48}
49
50inherit systemd
51
52SYSTEMD_SERVICE_${PN} = "atop.service"
53SYSTEMD_AUTO_ENABLE = "disable"
54
55FILES_${PN} += "${systemd_unitdir}/system-sleep"
56
57RDEPENDS_${PN} = "procps"