blob: 5cc6385dfb17abbe49be586bcb7baafcb0eb2579 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f"
6DEPENDS = "openssl websocketpp zlib boost brotli"
7
8EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake -DCPPREST_EXCLUDE_BROTLI=OFF"
9
10SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
11 file://disable-outside-tests.patch \
12 file://disable-test-timeouts.patch \
13 file://disable-float-tests.patch \
14 file://950-fix.patch \
15 file://system-brotli.patch \
16 "
17
18# tag 2.10.7
19SRCREV= "c4cef129e880a3f9c23a480e8c983793963173bb"
20
21S = "${WORKDIR}/git"
22
23inherit cmake