blob: 3de01ef5b67acda0f10c936d746f0f3c6bfcd810 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The glog library implements application-level logging. This \
2library provides logging APIs based on C++-style streams and various helper \
3macros."
4HOMEPAGE = "https://github.com/google/glog"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
8
9DEPENDS = "libunwind"
10
11SRC_URI = " \
12 git://github.com/google/glog.git;branch=v035 \
13 file://0001-Rework-CMake-glog-VERSION-management.patch \
14 file://0002-Find-Libunwind-during-configure.patch \
15 file://0003-installation-path-fix.patch \
16"
17
18SRCREV = "a6a166db069520dbbd653c97c2e5b12e08a8bb26"
19
20S = "${WORKDIR}/git"
21
22inherit cmake
23
24RDEPENDS_${PN} += "libunwind"
25
26EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"