blob: dcc9d68eaaa464f2dff13c4b246a37bd153f4633 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
2for the console and xterm, with sample clients included \
3(emacs, etc)."
4SECTION = "console/utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
7
8PV = "1.99.7+git${SRCREV}"
9PR = "r2"
10SRCREV = "1fd19417b8a4dd9945347e98dfa97e4cfd798d77"
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012DEPENDS = "ncurses bison-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
14SRC_URI = "git://github.com/telmich/gpm;protocol=git \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 file://init \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016 file://no-docs.patch \
17 file://processcreds.patch \
18 file://gpm.service.in \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 file://0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch \
20 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021
22S = "${WORKDIR}/git"
23
24inherit autotools-brokensep update-rc.d systemd
25
26INITSCRIPT_NAME = "gpm"
27INITSCRIPT_PARAMS = "defaults"
28
29do_configure_prepend() {
30 (cd ${S};./autogen.sh;cd -)
31}
32
33do_install_append () {
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
35 install -d ${D}${systemd_system_unitdir}
36 sed 's:@bindir@:${bindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service
37 fi
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
39 install -D -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
40 fi
41 install -D -m 0644 ${S}/src/headers/gpm.h ${D}${includedir}/gpm.h
42 ln -s libgpm.so.2 ${D}${libdir}/libgpm.so
43}
44
45SYSTEMD_SERVICE_${PN} = "gpm.service"
46
47FILES_${PN} += "${datadir}/emacs"