blob: 36530d2df0f43b361716014be3118b01b3012406 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
2for the development of SOAP Web Services and clients."
3SECTION = "devel"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
6 file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \
9 file://0001-Fix-out-of-tree-builds.patch \
10 file://0001-stdgsoap2-Fix-build-with-musl.patch \
11 "
12SRC_URI[md5sum] = "212951d6e1435bb51fa4320f458809ea"
13SRC_URI[sha256sum] = "3e7bb24a9e492f5cb86daca34054c9787152f1d7b70add36b789d03816d5ffa1"
14
15inherit autotools
16
17BBCLASSEXTEND = "native"
18
19S = "${WORKDIR}/${BPN}-2.8"
20
21PARALLEL_MAKE = ""
22
23EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
24
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025DEPENDS = "openssl zlib flex bison bison-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026DEPENDS_append_class-target = " gsoap-native"
27
28do_install_append() {
29 install -d ${D}${libdir}
30 for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
31 do
32 oe_libinstall -C gsoap $lib ${D}${libdir}
33 done
34}
35
36do_install_class-native() {
37 oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
38}
39
40FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
41FILES_${PN} += "${datadir}"
42FILES_${PN}-staticdev = "${libdir}"
43FILES_${PN}-dev = "${includedir}"
44RRECOMMENDS_${PN}-dev = "${PN}-staticdev"