blob: 01c856d123be7500e6af79f2eb799617642995ac [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Interactive process viewer"
2HOMEPAGE = "http://hisham.hm/htop"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c312653532e8e669f30e5ec8bdc23be3"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "http://hisham.hm/htop/releases/${PV}/${BP}.tar.gz \
10 file://0001-Use-pkg-config.patch"
11SRC_URI[md5sum] = "0d816b6beed31edc75babcfbf863ffa8"
12SRC_URI[sha256sum] = "d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57"
13
14inherit autotools pkgconfig
15
16PACKAGECONFIG ??= "proc \
17 cgroup \
18 taskstats \
19 unicode \
20 linux-affinity \
21 delayacct"
22PACKAGECONFIG[proc] = "--enable-proc,--disable-proc"
23PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
24PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup"
25PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
26PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats"
27PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
28PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity"
29PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc"
30PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid"
31PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
32
33do_configure_prepend () {
34 rm -rf ${S}/config.h
35}