blob: caf84de2c50c04503bd78e899ce566ddbd21d75a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The goal of this project is to provide a tiny library that would \
2facilitate the common operations with sizes in bytes."
3HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
4LICENSE = "LGPLv2+"
5SECTION = "devel/lib"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
12SRCREV = "b0dcf6f457d700127b43c0e0a198253c266b78ae"
13PV = "1.3+git${SRCPV}"
14SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
15"
16
17inherit gettext autotools python3native
18
19DEPENDS += " \
20 libpcre \
21 gmp \
22 mpfr \
23"
24
25FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
26
27PACKAGECONFIG ??= "python3"
28PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
29PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
30PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
31
32EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
33
34