blob: 542fe8157598b193560863ab67f27d03bcdb9e25 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "Tiny XML Library"
2LICENSE = "Mini-XML-License"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6ba38606d63bb042c5d8cfee182e120"
4HOMEPAGE = "https://www.msweet.org/mxml/"
5BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
6
7SRC_URI = "git://github.com/michaelrsweet/mxml.git"
8SRCREV = "ba3cca82e15a88a9cc6afb60f059288a99afc703"
9S = "${WORKDIR}/git"
10PV = "2.12+git${SRCPV}"
11
12CONFIGUREOPTS = " --prefix=${prefix} \
13 --bindir=${bindir} \
14 --sbindir=${sbindir} \
15 --libexecdir=${libexecdir} \
16 --datadir=${datadir} \
17 --sysconfdir=${sysconfdir} \
18 --sharedstatedir=${sharedstatedir} \
19 --localstatedir=${localstatedir} \
20 --libdir=${libdir} \
21 --includedir=${includedir} \
22 --oldincludedir=${oldincludedir} \
23 --infodir=${infodir} \
24 --mandir=${mandir} \
25 --host=${TARGET_SYS} \
26 --build=${BUILD_SYS} \
27 ${PACKAGECONFIG_CONFARGS} \
28 "
29
30do_configure() {
31 ./configure ${CONFIGUREOPTS} --enable-shared
32}
33
34do_install () {
35 export DSTROOT=${D}
36 oe_runmake install
37}
38
39PACKAGES += " ${PN}-bin "
40FILES_${PN} = "${libdir}/*"
41FILES_${PN}-bin = "${bindir}/*"