blob: 6040ec959ea1a6ed8847eb15adc9511220772dde [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
6
7DEPENDS = "zlib openssl libgcrypt"
8
9SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
10SRCREV = "789df0b7d0c7abd6b85db9fc5247e146e3d4ddba"
11
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16PACKAGECONFIG ??=""
17PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
18
19ARM_INSTRUCTION_SET_armv5 = "arm"
20
21EXTRA_OECMAKE = " \
22 -DWITH_GCRYPT=1 \
23 -DWITH_PCAP=1 \
24 -DWITH_SFTP=1 \
25 -DWITH_ZLIB=1 \
26 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
27 "
28
29do_configure_prepend () {
30 # Disable building of examples
31 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
32 || bbfatal "Failed to disable examples"
33}
34
35TOOLCHAIN = "gcc"