blob: dfca3855bf0a9f9081b5abcf3b3868434e617ac7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
9 file://run-ptest \
10"
11
12SRCREV = "6ed93e30f83519b0ab71f8ecd156b8ff0b2912b6"
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
16
17S = "${WORKDIR}/git"
18
19inherit autotools-brokensep ptest
20
21COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
22
23do_install_append() {
24 install -d ${D}${sysconfdir}/cron.hourly
25 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
26 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
27}
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}
31 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
32 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
33}
34
35RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"