blob: 5cc1546045e8f8b7b97eb9f5ef5b7ae55cb4bab7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2
3DESCRIPTION = "It provides tools to manage multipath devices \
4by instructing the device-mapper kernel module what to do. These \
5tools include: \
61. multipath - Scan the system for multipath devices and assemble them.\
72. multipathd - Detects when paths fail and execs multipath to update \
8things.\
93. mpathpersist - Persistent reservation management feature allows \
10cluster management software to manage persistent reservation through \
11mpath device. It processes management requests from callers and hides \
12the management task details. It also handles persistent reservation \
13management of data path life cycle and state changes.\
144. kpartx - This tool, derived from util-linux's partx, reads partition \
15tables on specified device and create device maps over partitions \
16segments detected. It is called from hotplug upon device maps creation \
17and deletion"
18
19HOMEPAGE = "http://christophe.varoqui.free.fr/"
20
21DEPENDS = "libdevmapper \
22 libaio \
23 liburcu \
24 readline \
25 udev \
26 json-c \
27 "
28
29LICENSE = "GPLv2"
30
31SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
32 file://multipathd.oe \
33 file://multipath.conf.example \
34 file://0001-multipath-tools-add-RDAC-SUN-ArrayStorage-to-hwtable.patch \
35 file://0002-multipath-tools-remove-c-from-__cpluscplus-misspelle.patch \
36 file://0003-multipath-tools-remove-emacs-autoconfig-of-kpartx-gp.patch \
37 file://0004-multipath-tools-replace-FSF-address-with-a-www-point.patch \
38 file://0005-multipath-tools-Remove-trailing-leading-whitespaces-.patch \
39 file://0006-multipath-tools-fix-compilation-with-musl-libc.patch \
40 file://0007-multipath-tools-add-x-to-doc-preclean.pl-and-split-m.patch \
41 file://0008-multipath-tools-refresh-kernel-doc-from-kernel-sourc.patch \
42 file://0009-multipath-tools-configure-hitachi-ams2000-and-hus100.patch \
43 file://0010-libmultipath-don-t-reject-maps-with-undefined-prio.patch \
44 file://0011-multipathd-handle-errors-in-uxlsnr-as-fatal.patch \
45 file://0012-libmultipath-fix-error-parsing-find_multipaths-stric.patch \
46 file://0013-libmultipath-print-correct-default-for-delay_-_check.patch \
47 file://0014-multipath.conf.5-clarify-property-whitelist-handling.patch \
48 file://0015-mpathpersist-add-all_tg_pt-option.patch \
49 file://0016-libmultipath-remove-rbd-code.patch \
50 file://0017-mpathpersist-fix-aptpl-support.patch \
51 file://0018-multipath-don-t-check-timestamps-without-a-path.patch \
52 file://0019-libmultipath-fix-detect-alua-corner-case.patch \
53 file://0020-multipath-fix-setting-conf-version.patch \
54 file://0021-RH-fixup-udev-rules-for-redhat.patch \
55 file://0022-RH-Remove-the-property-blacklist-exception-builtin.patch \
56 file://0023-RH-don-t-start-without-a-config-file.patch \
57 file://0024-RH-use-rpm-optflags-if-present.patch \
58 file://0025-RH-add-mpathconf.patch \
59 file://0026-RH-add-wwids-from-kernel-cmdline-mpath.wwids-with-A.patch \
60 file://0027-RH-warn-on-invalid-regex-instead-of-failing.patch \
61 file://0028-RH-reset-default-find_mutipaths-value-to-off.patch \
62 file://0029-multipath-tools-modify-Makefile.inc-for-cross-compil.patch \
63 file://0030-Always-use-devmapper.patch \
64 file://0031-Always-use-devmapper-for-kpartx.patch \
65 "
66
67LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
68
69SRCREV = "386d288b5595fc2c01dffe698b6eb306c6674908"
70
71S = "${WORKDIR}/git"
72
73inherit systemd pkgconfig
74
75SYSTEMD_SERVICE_${PN} = "multipathd.service"
76SYSTEMD_AUTO_ENABLE = "disable"
77
78TARGET_CC_ARCH += "${LDFLAGS}"
79
80# multipath-tools includes a copy of the valgrind.h header
81# file and uses the macros to suppress some false positives. However,
82# that only works on ARM when thumb is disabled. Otherwise one gets:
83# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
84# ../Makefile.inc:66: recipe for target 'debug.o' failed
85ARM_INSTRUCTION_SET_armv4 = "arm"
86ARM_INSTRUCTION_SET_armv5 = "arm"
87
88# The exact version of SYSTEMD does not matter but should be greater than 209.
89#
90EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
91 OPTFLAGS="${CFLAGS}" \
92 bindir=${base_sbindir} \
93 LIB=${base_libdir} libdir=${base_libdir}/multipath \
94 unitdir=${systemd_system_unitdir} \
95 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
96 '
97
98do_install() {
99 oe_runmake install
100
101 # We copy an initscript, but do not start multipathd at init time.
102 #
103 if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)};then
104 install -d ${D}${sysconfdir}/init.d
105 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
106 fi
107
108 install -d ${D}${sysconfdir}
109 install -m 0644 ${WORKDIR}/multipath.conf.example \
110 ${D}${sysconfdir}/multipath.conf.example
111}
112
113FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
114
115PACKAGES =+ "${PN}-libs"
116FILES_${PN}-libs = "${base_libdir}/lib*.so.* \
117 ${base_libdir}/multipath/lib*.so*"
118RDEPENDS_${PN} += "${PN}-libs bash"
119
120PROVIDES += "device-mapper-multipath"
121RPROVIDES_${PN} += "device-mapper-multipath"
122RPROVIDES_${PN}-libs += "device-mapper-multipath-libs"
123
124FILES_${PN}-dev += "${base_libdir}/pkgconfig"
125
126PACKAGES =+ "kpartx"
127FILES_kpartx = "${base_sbindir}/kpartx \
128 ${nonarch_libdir}/udev/kpartx_id \
129 "
130
131RDEPENDS_${PN} += "bash kpartx"