blob: 279ac041564d6c583cf8b912846593fb8c94d763 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
6LICENSE = "GPL-2.0 & LGPL-2.1"
7SECTION = "apps"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008
9inherit autotools-brokensep ptest
10
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013SRCREV = "841253d1313b01a968c380cae4f498f20c46e5aa"
14PV = "2.0.12+git${SRCPV}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
16SRC_URI = "git://github.com/numactl/numactl \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 file://0001-fix-NULL-pointer-problem.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018 file://Fix-the-test-output-format.patch \
19 file://Makefile \
20 file://run-ptest \
21 file://0001-define-run-test-target.patch \
22"
23
24S = "${WORKDIR}/git"
25
26# ARM does not currently support NUMA
27COMPATIBLE_HOST = "^((?!arm).*)$"
28
29do_install() {
30 oe_runmake DESTDIR=${D} prefix=${D}/usr install
31 #remove the empty man2 directory
32 rm -r ${D}${mandir}/man2
33}
34
35do_compile_ptest() {
36 oe_runmake test
37}
38
39do_install_ptest() {
40 #install tests binaries
41 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
42 mynode nodemap node-parse pagesize prefered randmap realloc_test \
43 tbitmap tshared"
44
45 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
46 for i in $test_binaries; do
47 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
48 done
49
50 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
51 shmtest runltp bind_range"
52 for i in $test_scripts; do
53 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
54 done
55
56 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
57 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
58}
59
60RDEPENDS_${PN}-ptest = "bash"