blob: 478d762cfb8d98ae9f9e1c69c947f9a4ec17c647 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14SECTION = "vmware-tools"
15
16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
18LICENSE_modules/freebsd/vmblock = "BSD"
19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0"
20LICENSE_modules/freebsd/vmxnet = "GPL-2.0"
21LICENSE_modules/linux = "GPL-2.0"
22LICENSE_modules/solaris = "CDDL-1.0"
23
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
25 file://tools.conf \
26 file://vmtoolsd.service \
27 file://vmtoolsd.init \
28 file://0001-configure.ac-don-t-use-dnet-config.patch \
29 file://0002-add-include-sys-sysmacros.h.patch \
30 file://0005-Use-configure-test-for-struct-timespec.patch \
31 file://0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch \
32 file://0007-Use-configure-to-test-for-feature-instead-of-platfor.patch \
33 file://0011-Use-configure-test-for-sys-stat.h-include.patch \
34 file://fix-subdir-objects-configure-error.patch \
35 file://0001-include-poll.h-instead-of-sys-poll.h.patch \
36 file://0002-Rename-poll.h-to-vm_poll.h.patch \
37 file://0003-use-posix-strerror_r-unless-on-gnu-libc-system.patch \
38 file://0004-Use-uintmax_t-for-handling-rlim_t.patch \
39 file://0001-Use-off64_t-instead-of-__off64_t.patch \
40 "
41SRCREV = "2147df6aabe639fc5ff423ed791a8e7f02bf8d0a"
42
43S = "${WORKDIR}/git/open-vm-tools"
44
45DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc"
46
47# open-vm-tools is supported only on x86.
48COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
49
50inherit autotools pkgconfig systemd update-rc.d
51
52SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
53
54EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
55 --disable-tests --without-gtkmm --without-xerces --without-pam \
56 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
57 --without-root-privileges --without-kernel-modules"
58
59NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
60X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
61PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
62
63# fuse gets implicitly detected; there is no --without-fuse option.
64PACKAGECONFIG[fuse] = ",,fuse"
65
66CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member"
67FILES_${PN} += "\
68 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
69 ${libdir}/open-vm-tools/plugins/common/lib*.so \
70 ${sysconfdir}/vmware-tools/tools.conf \
71 "
72FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
73FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
74FILES_${PN}-dbg += "\
75 ${libdir}/open-vm-tools/plugins/common/.debug \
76 ${libdir}/open-vm-tools/plugins/vmsvc/.debug \
77 "
78
79CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
80
81RDEPENDS_${PN} = "util-linux libdnet fuse"
82
83do_install_append() {
84 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
85 install -d ${D}${sysconfdir}/vmware-tools
86 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
87 install -d ${D}${systemd_unitdir}/system
88 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
89 else
90 install -d ${D}${sysconfdir}/init.d
91 install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
92 fi
93 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
94}
95
96do_configure_prepend() {
97 export CUSTOM_DNET_NAME=dnet
98 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
99}
100
101INITSCRIPT_PACKAGES = "${PN}"
102INITSCRIPT_NAME_${PN} = "vmtoolsd"
103INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
104
105python() {
106 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
107 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
108 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
109}
110