blob: 148e4b6b518930ec597bd221e63eace405acacb7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "multi-protocol instant messaging client"
2SECTION = "x11/network"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5DEPENDS = "python virtual/libintl intltool-native libxml2 gconf glib-2.0-native"
6
7inherit autotools gettext pkgconfig gconf perlnative
8
9SRC_URI = "\
10 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
11 file://sanitize-configure.ac.patch \
12 file://purple-OE-branding-25.patch \
13 file://pidgin-cross-python-265.patch \
14"
15
16SRC_URI[md5sum] = "8287400c4e5663e0e7844e868d5152af"
17SRC_URI[sha256sum] = "8c3d3536d6d3c971bd433ff9946678af70a0f6aa4e6969cc2a83bb357015b7f8"
18
19PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn nss \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
21"
22PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
23# --disable-gstreamer compile without GStreamer audio support
24# --disable-gstreamer-video
25# compile without GStreamer 1.0 Video Overlay support
26# --disable-gstreamer-interfaces
27# compile without GStreamer 0.10 interface support
28# --with-gstreamer=<version>
29# compile with GStreamer 0.10 or 1.0 interface
30PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
31PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
32PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
33PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
34PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
35PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
36PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,ncurses"
37PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls,libpurple-plugin-ssl-gnutls"
38PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
39PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
40PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss nspr,libpurple-plugin-ssl-nss"
41
42EXTRA_OECONF = " \
43 --disable-perl \
44 --disable-tcl \
45 --disable-gevolution \
46 --disable-schemas-install \
47 --disable-gtkspell \
48 --disable-meanwhile \
49 --disable-nm \
50 --disable-screensaver \
51"
52
53do_configure_prepend() {
54 touch ${S}/po/Makefile
55 sed -i "s#PY_VERSION=`$PYTHON -c 'import sys ; print sys.version[0:3]'`#PY_VERSION=${PYTHON_BASEVERSION}#g" ${S}/configure.ac
56}
57
58OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
59OE_LT_RPATH_ALLOW[export]="1"
60
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061PACKAGES =+ "libpurple-dev libpurple libgnt libgnt-dev finch finch-dev ${PN}-data"
62
63RPROVIDES_${PN}-dbg += "libpurple-dbg libgnt-dbg finch-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050064
65LEAD_SONAME = "libpurple.so.0"
66FILES_libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
67FILES_libpurple-dev = "${libdir}/libpurple*.la \
68 ${libdir}/libpurple*.so \
69 ${libdir}/purple-2/*.la \
70 ${libdir}/purple-2/libjabber.so \
71 ${libdir}/purple-2/liboscar.so \
72 ${libdir}/purple-2/libymsg.so \
73 ${datadir}/aclocal"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050074FILES_libgnt = "${libdir}/libgnt.so.* ${libdir}/gnt/*.so"
75FILES_libgnt-dev = "${libdir}/gnt/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050076FILES_finch = "${bindir}/finch"
77FILES_finch-dev = "${libdir}/finch/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050078
79FILES_${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
80 ${datadir}/applications"
81RRECOMMENDS_${PN} = "${PN}-data libpurple-protocol-irc libpurple-protocol-xmpp"
82
83FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
84FILES_${PN}-dev += "${libdir}/${PN}/*.la"
85
86PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
87
88python populate_packages_prepend () {
89 pidgroot = d.expand('${libdir}/pidgin')
90 purple = d.expand('${libdir}/purple-2')
91 finch = d.expand('${libdir}/finch')
92
93 do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$',
94 output_pattern='pidgin-plugin-%s',
95 description='Pidgin plugin %s',
96 prepend=True, extra_depends='')
97
98 do_split_packages(d, purple, '^lib(.*)\.so$',
99 output_pattern='libpurple-protocol-%s',
100 description='Libpurple protocol plugin for %s',
101 prepend=True, extra_depends='')
102
103 do_split_packages(d, purple, '^(ssl-.*)\.so$',
104 output_pattern='libpurple-plugin-%s',
105 description='libpurple plugin %s',
106 prepend=True, extra_depends='libpurple-plugin-ssl')
107
108 do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$',
109 output_pattern='libpurple-plugin-%s',
110 description='libpurple plugin %s',
111 prepend=True, extra_depends='')
112
113 do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$',
114 output_pattern='finch-plugin-%s',
115 description='Finch plugin %s',
116 prepend=True, extra_depends='')
117}