blob: a09bea23d4e19b7db84e47e158e962e8a11c9db8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
12"
13SRCREV = "4baa0c765071054314d1e7e78547ce6b7c133fbc"
14S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
20"
21
22PACKAGES += "python3-${PN}"
23FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
24
25PACKAGECONFIG ??= "python3 rpm"
26PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
27PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
28PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
29
30do_configure_prepend() {
31 ${S}/gen-version
32}