blob: 3e8f2d4f519dbf84251e5375a0f39bcdb422a21f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A tool to load and stress a computer system"
2HOMEPAGE = "http://kernel.ubuntu.com/~cking/stress-ng/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6DEPENDS = "zlib libaio"
7
8SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch \
10 "
11SRC_URI_append_libc-musl = " \
12 file://0001-Several-changes-to-fix-musl-build.patch \
13 "
14
15SRC_URI[md5sum] = "b03744c2eb68bf7e9a300e78e397f348"
16SRC_URI[sha256sum] = "0741e3004bf590bb7af3db979a46fe89bee7aaad6065cd1d87d0b7fa49046cb2"
17
18UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/"
19UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar"
20
21CFLAGS += "-Wall -Wextra -DVERSION='"$(VERSION)"'"
22
23do_install_append() {
24 install -d ${D}${bindir}
25 install -m 755 ${S}/stress-ng ${D}${bindir}/stress-ng
26}