blob: 3fa6294f1c591c16bb876d28be44ad0fe674f5aa [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "DNSSEC extensions to Net::DNS"
2HOMEPAGE = "http://www.net-dns.org/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://README;beginline=165;endline=192;md5=6ef523fa09e8c272675839e21de16bde"
7
8SRC_URI = "https://cpan.metacpan.org/authors/id/W/WI/WILLEM/Net-DNS-SEC-${PV}.tar.gz"
9SRC_URI[md5sum] = "ffa55a9898192c9d4c623cb1357eba9b"
10SRC_URI[sha256sum] = "37a47d4def72d7338f3cc7cd807ec19bd9e2ae638ae656fa536cf0314801989e"
11
12DEPENDS += "openssl"
13
14UPSTREAM_CHECK_REGEX = "Net\-DNS\-SEC\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
15
16S = "${WORKDIR}/Net-DNS-SEC-${PV}"
17
18EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_BASELIBDIR} -lcrypto'"
19
20inherit cpan ptest-perl
21
22RDEPENDS_${PN} = " \
23 libnet-dns-perl \
24 libcrypto \
25 perl-module-dynaloader \
26 perl-module-file-find \
27 perl-module-file-spec \
28 perl-module-io-file \
29 perl-module-mime-base64 \
30 perl-module-test-more \
31"
32
33BBCLASSEXTEND = "native"