blob: b3f7240547acc03a1de8b788ae5c813ac2cad4f1 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT & AFL-2.1 | GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
6 file://dbus-gmain/COPYING;md5=05c3eacd50f69bb1d58afec460baad57 "
7DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
8
9SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "7379db774c10904f27e7e2743d90fb43"
13SRC_URI[sha256sum] = "abf12bbb765e300bf8e2a1b2f32f85949eab06998dbda127952c31cb63957b6f"
14S = "${WORKDIR}/dbus-python-${PV}"
15
16inherit distutils-base autotools pkgconfig
17
18# documentation needs python-sphinx, which is not in oe-core or meta-python for now
19# change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python
20EXTRA_OECONF += "--disable-documentation"
21
22export STAGING_LIBDIR
23export STAGING_INCDIR
24
25RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
26
27FILES_${PN}-dev += "${libdir}/pkgconfig"
28
29do_install_append() {
30 # Remove files that clash with python3-dbus; their content is same
31 rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
32}