blob: dc587e761e717cef83361bda063ecdf3995cde70 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Convenience functions for dbus services in Python 2.x"
2HOMEPAGE = "http://nphilipp.fedorapeople.org/python-slip/"
3DESCRIPTION = "\
4The Simple Library for Python 2.x packages contain miscellaneous code for \
5convenience, extension and workaround purposes. \
6\
7This package provides slip.dbus.service.Object, which is a dbus.service.Object \
8derivative that ends itself after a certain time without being used and/or if \
9there are no clients anymore on the message bus, as well as convenience \
10functions and decorators for integrating a dbus service with PolicyKit."
11
12SECTION = "devel/python"
13LICENSE = "GPLv2+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
15SRCNAME = "python-slip"
16
17SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit setuptools
21
22SRC_URI[md5sum] = "a6d8ee96245fc21785d4c1c062c85f2f"
23SRC_URI[sha256sum] = "bc897f1ab6f5b4989f85548799aaeb84fde67bbba18e40341bfe1d7885c2fd9a"
24
25do_compile_prepend() {
26 sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
27}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
29# http://errors.yoctoproject.org/Errors/Details/184713/
30# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
31CLEANBROKEN = "1"