blob: 2ce6bdbd68b711b7142e94532ed939312abcb636 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001inherit setuptools3
2require python-cython.inc
3
4RDEPENDS_${PN} += "\
5 python3-setuptools \
6"
7
8# running build_ext a second time during install fails, because Python
9# would then attempt to import cythonized modules built for the target
10# architecture.
11DISTUTILS_INSTALL_ARGS += "--skip-build"
12
13do_install_append() {
14 # rename scripts that would conflict with the Python 2 build of Cython
15 mv ${D}${bindir}/cython ${D}${bindir}/cython3
16 mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
17 mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
18}