blob: eb42fe978c5dae57d2c44ae51ab0022a15b7d30a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
2keyboard, territory"
3HOMEPAGE = "https://github.com/mike-fabian/langtable/"
4LICENSE = "GPLv3+"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
12SRCREV = "35687ca957b746f153a6872139462b1443f8cad1"
13PV = "0.0.38+git${SRCPV}"
14SRC_URI = "git://github.com/mike-fabian/langtable.git;branch=master \
15"
16
17inherit setuptools3 python3native
18
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019DISTUTILS_INSTALL_ARGS += " \
20 --install-data=${datadir}/langtable"
Brad Bishop316dfdd2018-06-25 12:45:53 -040021
22FILES_${PN} += "${datadir}/*"
23
24RDEPENDS_${PN} += " \
25 ${PYTHON_PN}-compression \
26 ${PYTHON_PN}-doctest \
27 ${PYTHON_PN}-logging \
28 ${PYTHON_PN}-xml \
29"