blob: 54620a0661744d0bce7f644a2133b0738126e0fb [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Control process attributes through prctl"
2DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \
3process' behaviour. Usage of the function is fairly messy though, due to \
4limitations in C and linux. This module provides a nice non-messy python(ic) \
5interface."
6SECTION = "devel/python"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=23ff9f50449d4bd0e513df16e4d9755f"
9
10S = "${WORKDIR}/git"
11B = "${S}"
12
13SRCREV = "57cd0a7cad76e8f8792eea22ee5b5d17bae0a90f"
14PV = "1.7+git${SRCPV}"
15
16SRC_URI = "git://github.com/seveas/python-prctl;branch=master \
17 file://0001-support-cross-complication.patch \
18"
19inherit setuptools3 python3native
20
21DEPENDS += "libcap"
22