blob: 75f02f13db94c9635ff5c6f284af1bbae7fdf2a2 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A python module for system storage configuration"
2HOMEPAGE = "http://fedoraproject.org/wiki/blivet"
3LICENSE = "LGPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "ddc24c71bad10208b11ea0c45853898fadd7030b"
12SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \
13 file://0001-comment-out-selinux.patch \
14 file://0002-run_program-support-timeout.patch \
15 file://0003-support-infinit-timeout.patch \
16 file://0004-fix-new.roots-object-is-not-iterable.patch \
17 file://0005-fix-incorrect-timeout-while-system-time-changed.patch \
18 file://0006-tweak-btrfs-packages.patch \
19 file://0007-invoking-mount-with-infinite-timeout.patch \
20 file://0008-use-oe-variable-to-replace-hardcoded-dir.patch \
21 file://0009-invoking-fsck-with-infinite-timeout.patch \
22 file://0010-invoking-mkfs-with-infinite-timeout.patch \
23 file://0011-invoking-dd-with-infinite-timeout.patch \
24 file://0012-remove-dmraid-dependency-check.patch \
25 file://0013-add-Z-y-and-y-to-lvm.pvcreate.patch \
26"
27
28UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$"
29
30inherit distro_features_check
31REQUIRED_DISTRO_FEATURES = "systemd"
32
33inherit setuptools3 python3native
34
35RDEPENDS_${PN} = "python3-pykickstart python3-pyudev \
36 parted python3-pyparted multipath-tools \
37 lsof cryptsetup libblockdev \
38 libbytesize \
39"
40
41FILES_${PN} += " \
42 ${datadir}/dbus-1/system-services \
43"
44
45inherit systemd
46
47SYSTEMD_AUTO_ENABLE = "disable"
48SYSTEMD_SERVICE_${PN} = "blivet.service"