blob: 91f0dff71c193d2c836db1251afd2f7cdc4c46f5 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "a4fd427ee2acc5a8f5fb030bf7816917cee63bd8"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
13"
14
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "x11 systemd"
17
18inherit setuptools3 python3native
19
20RDEPENDS_${PN} = "python3-pygobject python3 \
21 python3-blivet gtk+3 \
22 python3-pid libreport \
23"
24
25FILES_${PN} += " \
26 ${datadir}/* \
27 "