blob: d7719051b1e3b6a42b7b5337049881c4fdbcbc2c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Easily themable notification daemon with transparency effects"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-notifyd"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = " \
6 dbus \
7 dbus-glib \
8 dbus-glib-native \
9 libnotify \
10 libxfce4util \
11 libxfce4ui \
12 xfconf \
13 xfce4-panel \
14"
15
16inherit xfce-app
17
18SRC_URI[md5sum] = "4887c62dfcb4c3e4f45c9acfb3def515"
19SRC_URI[sha256sum] = "293dda084cfca4887ae740e2725fdfc64412bc10eac7a55a924eb14482dceac0"
20
21# Avoid trouble with other desktops e.g KDE which also ships dbus service named
22# org.freedesktop.Notifications
23EXTRA_OECONF = "--disable-dbus-start-daemon"
24
25do_compile_prepend() {
26 mkdir -p xfce4-notifyd xfce4-notifyd-config
27}
28
29FILES_${PN} += " \
30 ${systemd_user_unitdir} \
31 ${datadir}/xfce4 \
32 ${datadir}/themes \
33 ${datadir}/dbus-1 \
34 ${libdir}/xfce4 \
35"