blob: a6475cef6d671ecb32c62499b0ca964f094775a0 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Library for supporting single instance GTK+ applications"
2DESCRIPTION = "Unique is a library for writing single instance GTK+ applications. If you launch a single instance application twice, the second instance will either just quit or will send a message to the running instance."
3HOMEPAGE = "https://wiki.gnome.org/Attic/LibUnique"
4BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=libunique"
5
6SRC_URI = "${GNOME_MIRROR}/libunique/1.1/libunique-${PV}.tar.bz2 \
7 file://fix_for_compile_with_gcc-4.6.0.patch \
8 file://noconst.patch \
9 file://build.patch \
10 file://0001-Makefile.am-use-LIBTOOL-instead-of-hardcoded-libtool.patch \
11 file://0001-test-unique-Add-format-qualifier-s-for-string.patch \
12 "
13
14SRC_URI[md5sum] = "7955769ef31f1bc4f83446dbb3625e6d"
15SRC_URI[sha256sum] = "e5c8041cef8e33c55732f06a292381cb345db946cf792a4ae18aa5c66cdd4fbb"
16
17PR = "r7"
18
19DEPENDS = "dbus-glib-native glib-2.0 gtk+"
20
21PACKAGECONFIG ??= "dbus"
22PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
23
24LICENSE = "LGPLv2.1"
25LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
26
27
28inherit autotools pkgconfig gobject-introspection distro_features_check gtk-doc
29
30REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32do_install_append () {
33 rmdir --ignore-fail-on-non-empty ${D}${datadir}
34}