blob: 2b4e97490d83707fff78be65041ffae255491f23 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "Parole is a modern simple media player based on the GStreamer framework"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/parole"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6inherit xfce-app gtk-doc mime
7
8DEPENDS += " \
9 glib-2.0 \
10 dbus-glib \
11 gtk+3 \
12 \
13 xfce4-dev-tools-native \
14 libxfce4util \
15 libxfce4ui \
16 xfconf \
17 \
18 gstreamer1.0-plugins-base \
19 taglib \
20"
21
22SRC_URI[md5sum] = "46fe86bbe0c4aa02c53244d66e62e90c"
23SRC_URI[sha256sum] = "8ad2931fdb35415cc3d7551b5f2207bfaa1aba15545accbacbb4984cdabd7099"
24
25RDEPENDS_${PN} += "gstreamer1.0-plugins-good"
26
27EXTRA_OECONF = "--disable-gtk-doc"
28
29PACKAGECONFIG ??= "notify"
30PACKAGECONFIG[clutter] = "--enable-clutter, --disable-clutter, clutter"
31PACKAGECONFIG[notify] = "--enable-notify-plugin, --disable-notify-plugin, libnotify"
32
33FILES_${PN} += " \
34 ${datadir}/appdata \
35 ${libdir}/parole-0/*.so \
36"
37
38FILES_${PN}-dev += "${libdir}/parole-0/*.la"