blob: 9c4829bbf88c1fb7f8954f623070656cf1167f7e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION="Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
6DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
7
8inherit xfce pythonnative perlnative gtk-doc distro_features_check
9
10REQUIRED_DISTRO_FEATURES = "x11"
11REQUIRED_DISTRO_FEATURES_class-native = ""
12
13# SRC_URI must follow inherited one
14SRC_URI += " \
15 file://exo-no-tests-0.8.patch \
16 file://configure.patch \
17"
18
19SRC_URI_append_class-native = " \
20 file://reduce-build-to-exo-csource-only.patch \
21"
22
23SRC_URI[md5sum] = "da934c5939f2ee4540f5d48991053f01"
24SRC_URI[sha256sum] = "b96fe86bb504aa9b3332b96105d755f5d9052c903fd6574b512a5ef76c0ad439"
25
26PACKAGES =+ "exo-csource"
27
28# Note: python bindings did not work in oe-dev and are about to be moved to
29# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
30FILES_${PN} += "${datadir}/xfce4/ \
31 ${libdir}/xfce4/exo-1 \
32"
33
34FILES_exo-csource += "${bindir}/exo-csource"
35
36BBCLASSEXTEND = "native"