blob: 9d2669475f0f636adbc1b41a1a27708472b2e876 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION="Thumbnail service implementing the thumbnail management D-Bus specification"
2SECTION = "x11/libs"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "dbus-glib dbus-glib-native freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf"
6
7inherit xfce gtk-doc
8
9SRC_URI[md5sum] = "dd5f9bae6a2470eb5fff0dc9edd3ea09"
10SRC_URI[sha256sum] = "4e27a59694b0a5cc69ebccbdb00c724e670b5b7c30bc4dc0b461aac93f234fac"
11SRC_URI += "file://0001-configure-use-pkg-config-for-freetype2.patch"
12
13INSANE_SKIP_${PN} = "dev-so"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
17
18do_install_append() {
19 # Makefile seems to race on creation of symlink. So ensure creation here
20 # until fixed properly
21 ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
22}
23
24FILES_${PN} += "${datadir}/dbus-1/services \
25 ${libdir}/tumbler-1/tumblerd \
26 ${libdir}/tumbler-1/plugins/*.so \
27 ${libdir}/tumbler-1/plugins/cache/*.so \
28"
29
30FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031 ${libdir}/tumbler-1/plugins/cache/*.la \
Brad Bishop316dfdd2018-06-25 12:45:53 -040032"