blob: 7d6ab84e4932e4d99acffb5e0929d97532433ab8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \
2 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2 linuxfb', \
3 '', d), d)}"
4#PACKAGECONFIG_GL_rpi = "${@bb.utils.any_distro_features('x11 wayland', '', 'eglfs', d)}"
5PACKAGECONFIG_FONTS_rpi = "fontconfig"
6PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon-evdev"
7PACKAGECONFIG_remove_rpi = "tests"
8
9OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'eglfs_kms', 'eglfs_brcm', d)}"
10
11do_configure_prepend_rpi() {
12 # Add the appropriate EGLFS_DEVICE_INTEGRATION
13 if [ "${@d.getVar('OE_QTBASE_EGLFS_DEVICE_INTEGRATION')}" != "" ]; then
14 echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" > ${S}/mkspecs/oe-device-extra.pri
15 fi
16}
17RDEPENDS_${PN}_append_rpi = " userland"