blob: 88ef19f7322b0dce082ac8c3c05d310d905fcdae [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The tpm-tools package contains commands to allow the platform administrator the ability to manage and diagnose the platform's TPM."
2DESCRIPTION = " \
3 The tpm-tools package contains commands to allow the platform administrator \
4 the ability to manage and diagnose the platform's TPM. Additionally, the \
5 package contains commands to utilize some of the capabilities available \
6 in the TPM PKCS#11 interface implemented in the openCryptoki project. \
7 "
8SECTION = "tpm"
9LICENSE = "CPL-1.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=059e8cd6165cb4c31e351f2b69388fd9"
11
12DEPENDS = "libtspi openssl"
13DEPENDS_class-native = "trousers-native"
14
15SRCREV = "bdf9f1bc8f63cd6fc370c2deb58d03ac55079e84"
16SRC_URI = " \
17 git://git.code.sf.net/p/trousers/tpm-tools \
18 file://tpm-tools-extendpcr.patch \
19 file://04-fix-FTBFS-clang.patch \
20 file://05-openssl1.1_fix_data_mgmt.patch \
21 file://openssl1.1_fix.patch \
22 "
23
24inherit autotools-brokensep gettext
25
26S = "${WORKDIR}/git"
27
28do_configure_prepend () {
29 mkdir -p po
30 mkdir -p m4
31 cp -R po_/* po/
32 touch po/Makefile.in.in
33 touch m4/Makefile.am
34}
35
36BBCLASSEXTEND = "native"