blob: 8847a0fc440f442446337e8771be9dd25f2e1c7c [file] [log] [blame]
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +05301SUMMARY = "low-level tool handling Linux filesystem encryption"
2DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \
3policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \
4For a tool that presents a higher level interface and manages metadata, key \
5generation, key wrapping, PAM integration, and passphrase hashing, see \
6fscrypt (https://github.com/google/fscrypt)."
7HOMEPAGE = "https://github.com/google/fscryptctl"
8SECTION = "base"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRCREV = "142326810eb19d6794793db6d24d0775a15aa8e5"
Richard Marian Thomaiyar14fddef2018-07-13 23:55:56 +053013SRC_URI = "git://github.com/google/fscryptctl.git"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 oe_runmake DESTDIR=${D}${bindir} install
19}
20
21RRECOMMENDS_${PN} += "\
22 keyutils \
23 kernel-module-cbc \
24 kernel-module-cts \
25 kernel-module-ecb \
26 kernel-module-xts \
27"