blob: 8f7f805fd2861b0b3b69e9b0fb7aae1033207911 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "system security services daemon"
2DESCRIPTION = "SSSD is a system security services daemon"
3HOMEPAGE = "https://pagure.io/SSSD/sssd/"
4SECTION = "base"
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "openldap cyrus-sasl libtdb ding-libs libpam c-ares krb5 autoconf-archive"
9DEPENDS += "libldb dbus libtalloc libpcre glib-2.0 popt e2fsprogs libtevent"
10
11SRC_URI = "https://releases.pagure.org/SSSD/${BPN}/${BP}.tar.gz\
12 file://sssd.conf "
13
14SRC_URI[md5sum] = "af4288c9d1f9953e3b3b6e0b165a5ece"
15SRC_URI[sha256sum] = "ee5d17a0c663c09819cbab9364085b9e57faeca02406cc30efe14cc0cfc04ec4"
16
17inherit autotools pkgconfig gettext update-rc.d python-dir distro_features_check
18
19REQUIRED_DISTRO_FEATURES = "pam"
20
21CACHED_CONFIGUREVARS = "ac_cv_member_struct_ldap_conncb_lc_arg=no \
22 ac_cv_path_NSUPDATE=${bindir} \
23 ac_cv_path_PYTHON2=${PYTHON_DIR} ac_cv_prog_HAVE_PYTHON3=${PYTHON_DIR} \
24 "
25
26PACKAGECONFIG ?="nss nscd"
27PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
28
29PACKAGECONFIG[ssh] = "--with-ssh, --with-ssh=no, "
30PACKAGECONFIG[samba] = "--with-samba, --with-samba=no, samba"
31PACKAGECONFIG[selinux] = "--with-selinux, --with-selinux=no --with-semanage=no, libselinux"
32PACKAGECONFIG[manpages] = "--with-manpages, --with-manpages=no"
33PACKAGECONFIG[python2] = "--with-python2-bindings, --without-python2-bindings"
34PACKAGECONFIG[python3] = "--with-python3-bindings, --without-python3-bindings"
35PACKAGECONFIG[nss] = "--with-crypto=nss, ,nss,"
36PACKAGECONFIG[cyrpto] = "--with-crypto=libcrypto, , libcrypto"
37PACKAGECONFIG[nscd] = "--with-nscd=${sbindir}, --with-nscd=no "
38PACKAGECONFIG[nl] = "--with-libnl, --with-libnl=no, libnl"
39PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_unitdir}/system/, --with-systemdunitdir="
40PACKAGECONFIG[http] = "--with-secrets, --without-secrets, apache2"
41PACKAGECONFIG[curl] = "--with-secrets --with-kcm, --without-secrets --without-kcm, curl"
42
43EXTRA_OECONF += "--disable-cifs-idmap-plugin --without-nfsv4-idmapd-plugin --without-ipa-getkeytab"
44
45do_configure_prepend() {
46 mkdir -p ${AUTOTOOLS_AUXDIR}/build
47 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/build/
48
49 # libresove has host path, remove it
50 sed -i -e "s#\$sss_extra_libdir##" ${S}/src/external/libresolv.m4
51}
52
53do_install () {
54 oe_runmake install DESTDIR="${D}"
55 rmdir --ignore-fail-on-non-empty "${D}/${bindir}"
56 install -d ${D}/${sysconfdir}/${BPN}
57 install -m 600 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN}
58}
59
60CONFFILES_${PN} = "${sysconfdir}/${BPN}/${BPN}.conf"
61
62INITSCRIPT_NAME = "sssd"
63INITSCRIPT_PARAMS = "start 02 5 3 2 . stop 20 0 1 6 ."
64SYSTEMD_SERVICE_${PN} = "${BPN}.service"
65SYSTEMD_AUTO_ENABLE = "disable"
66
67FILES_${PN} += "${libdir} ${datadir} /run ${libdir}/*.so* "
68FILES_${PN}-dev = " ${includedir}/* ${libdir}/*la ${libdir}/*/*la"
69
70# The package contains symlinks that trip up insane
71INSANE_SKIP_${PN} = "dev-so"
72
73RDEPENDS_${PN} += "bind dbus"