blob: 32509b07868f7519032cbd9ba9af5d021e390b78 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001SUMMARY = "Xilinx Platform Headers"
2DESCRPTION = "Xilinx ps*_init_gpl.c/h platform init code, used for building u-boot-spl and fsbl"
3HOMEPAGE = "http://www.xilinx.com"
4SECTION = "bsp"
5
6INHIBIT_DEFAULT_DEPS = "1"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10inherit xilinx-platform-init
11
12COMPATIBLE_MACHINE = "$^"
13COMPATIBLE_MACHINE_picozed-zynq7 = "picozed-zynq7"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
17
18PROVIDES += "virtual/xilinx-platform-init"
19
20SRC_URI = "${@" ".join(["file://%s" % f for f in (d.getVar('PLATFORM_INIT_FILES') or "").split()])}"
21
22S = "${WORKDIR}"
23
24SYSROOT_DIRS += "${PLATFORM_INIT_DIR}"
25
26do_compile() {
27 :
28}
29
30do_install() {
31 install -d ${D}${PLATFORM_INIT_DIR}
32 for i in ${PLATFORM_INIT_FILES}; do
33 install -m 0644 ${S}/$i ${D}${PLATFORM_INIT_DIR}/
34 done
35}
36
37FILES_${PN} += "${PLATFORM_INIT_DIR}/*"
38