blob: 8d1380f05a93bd8b29e47bc152f37ec256032175 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001SUMMARY = "Linux kernel module for Video Code Unit"
2DESCRIPTION = "Out-of-tree VCU decoder, encoder and common kernel modules provider for MPSoC EV devices"
3SECTION = "kernel/modules"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eb723b61539feef013de476e68b5c50a"
6
7XILINX_VCU_VERSION = "1.0.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008XILINX_RELEASE_VERSION = "2018.3"
Brad Bishop286d45c2018-10-02 15:21:57 -04009PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
10
11S = "${WORKDIR}/git"
12
13BRANCH ?= "master"
14REPO ?= "git://github.com/xilinx/vcu-modules.git;protocol=https"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015SRCREV ?= "f6a9093ec32ee97a2df065aee8b8e676c2024f01"
Brad Bishop286d45c2018-10-02 15:21:57 -040016
17BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
18SRC_URI = "${REPO};${BRANCHARG}"
19
20inherit module
21
22EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
23
24RDEPENDS_${PN} = "vcu-firmware"
25
26COMPATIBLE_MACHINE = "^$"
27COMPATIBLE_MACHINE_zynqmp = "zynqmp"
28
29PACKAGE_ARCH = "${SOC_FAMILY}"