blob: 18fa032cc7fd4a5dff664c588c6c15c5cdc5dd9a [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001SUMMARY = "OpenMAX Integration layer for VCU"
2DESCRIPTION = "OMX IL Libraries,test applications and headers for VCU"
3LICENSE = "Proprietary"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493"
5
6XILINX_VCU_VERSION = "1.0.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007XILINX_RELEASE_VERSION = "2018.3"
Brad Bishop286d45c2018-10-02 15:21:57 -04008PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
9
10BRANCH ?= "master"
11REPO ?= "git://github.com/xilinx/vcu-omx-il.git;protocol=https"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRCREV ?= "cf4b031ac88c7889e4f29ac7fc8ca7592bf12144"
Brad Bishop286d45c2018-10-02 15:21:57 -040013
14BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
15SRC_URI = "${REPO};${BRANCHARG}"
16
17S = "${WORKDIR}/git"
18
19COMPATIBLE_MACHINE = "^$"
20COMPATIBLE_MACHINE_zynqmp = "zynqmp"
21
22PACKAGE_ARCH = "${SOC_FAMILY}"
23
24DEPENDS = "libvcu-xlnx"
25RDEPENDS_${PN} = "kernel-module-vcu libvcu-xlnx"
26
27EXTERNAL_INCLUDE="${STAGING_INCDIR}/vcu-ctrl-sw/include"
28
29EXTRA_OEMAKE = " \
30 CC='${CC}' CXX='${CXX} ${CXXFLAGS}' \
31 EXTERNAL_INCLUDE='${EXTERNAL_INCLUDE}' \
32 "
33
34do_install() {
35 install -d ${D}${libdir}
36 install -d ${D}${includedir}/vcu-omx-il
37
38 install -m 0644 ${S}/omx_header/*.h ${D}${includedir}/vcu-omx-il
39
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040 install -Dm 0755 ${S}/bin/omx_decoder ${D}/${bindir}/omx_decoder
41 install -Dm 0755 ${S}/bin/omx_encoder ${D}/${bindir}/omx_encoder
Brad Bishop286d45c2018-10-02 15:21:57 -040042
43 oe_libinstall -C ${S}/bin/ -so libOMX.allegro.core ${D}/${libdir}/
44 oe_libinstall -C ${S}/bin/ -so libOMX.allegro.video_decoder ${D}/${libdir}/
45 oe_libinstall -C ${S}/bin/ -so libOMX.allegro.video_encoder ${D}/${libdir}/
46}
47
48# These libraries shouldn't get installed in world builds unless something
49# explicitly depends upon them.
50
51EXCLUDE_FROM_WORLD = "1"