blob: b068aa81f06229e1f0c1de31d711b1e50b4e52dd [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001SUMMARY = "Control Software for VCU"
2DESCRIPTION = "Control software libraries, test applications and headers provider for VCU"
3LICENSE = "Proprietary"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493"
5
6XILINX_VCU_VERSION = "1.0.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007XILINX_RELEASE_VERSION = "2018.3"
Brad Bishop286d45c2018-10-02 15:21:57 -04008PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
9
10BRANCH ?= "master"
11REPO ?= "git://github.com/xilinx/vcu-ctrl-sw.git;protocol=https"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012SRCREV ?= "1cb5281d319ea4f3c0eb5514864c80d95e78fe6e"
Brad Bishop286d45c2018-10-02 15:21:57 -040013
14BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
15SRC_URI = "${REPO};${BRANCHARG}"
16
17S = "${WORKDIR}/git"
18
19COMPATIBLE_MACHINE = "^$"
20COMPATIBLE_MACHINE_zynqmp = "zynqmp"
21
22PACKAGE_ARCH = "${SOC_FAMILY}"
23
24RDEPENDS_${PN} = "kernel-module-vcu"
25
26EXTRA_OEMAKE = "CC='${CC}' CXX='${CXX} ${CXXFLAGS}'"
27
28do_install() {
29 install -d ${D}${libdir}
30 install -d ${D}${includedir}/vcu-ctrl-sw/include
31
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032 install -Dm 0755 ${S}/bin/ctrlsw_encoder ${D}/${bindir}/ctrlsw_encoder
33 install -Dm 0755 ${S}/bin/ctrlsw_decoder ${D}/${bindir}/ctrlsw_decoder
Brad Bishop286d45c2018-10-02 15:21:57 -040034
35 oe_runmake install_headers INSTALL_HDR_PATH=${D}${includedir}/vcu-ctrl-sw/include
36 oe_libinstall -C ${S}/bin/ -so liballegro_decode ${D}/${libdir}/
37 oe_libinstall -C ${S}/bin/ -so liballegro_encode ${D}/${libdir}/
38}
39
40# These libraries shouldn't get installed in world builds unless something
41# explicitly depends upon them.
42
43EXCLUDE_FROM_WORLD = "1"