blob: 3cbdcf18c20e900c382c05c0bb1e13dd601fbf32 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit siteinfo python3native
Brad Bishop316dfdd2018-06-25 12:45:53 -04002
3DEPENDS_append = " meson-native ninja-native"
4
5# As Meson enforces out-of-tree builds we can just use cleandirs
6B = "${WORKDIR}/build"
7do_configure[cleandirs] = "${B}"
8
9# Where the meson.build build configuration is
10MESON_SOURCEPATH = "${S}"
11
12def noprefix(var, d):
13 return d.getVar(var).replace(d.getVar('prefix') + '/', '', 1)
14
15MESONOPTS = " --prefix ${prefix} \
16 --buildtype plain \
17 --bindir ${@noprefix('bindir', d)} \
18 --sbindir ${@noprefix('sbindir', d)} \
19 --datadir ${@noprefix('datadir', d)} \
20 --libdir ${@noprefix('libdir', d)} \
21 --libexecdir ${@noprefix('libexecdir', d)} \
22 --includedir ${@noprefix('includedir', d)} \
23 --mandir ${@noprefix('mandir', d)} \
24 --infodir ${@noprefix('infodir', d)} \
25 --sysconfdir ${sysconfdir} \
26 --localstatedir ${localstatedir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027 --sharedstatedir ${sharedstatedir} \
28 -Dc_args='${BUILD_CPPFLAGS} ${BUILD_CFLAGS}' \
29 -Dc_link_args='${BUILD_LDFLAGS}' \
30 -Dcpp_args='${BUILD_CPPFLAGS} ${BUILD_CXXFLAGS}' \
31 -Dcpp_link_args='${BUILD_LDFLAGS}'"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
33MESON_TOOLCHAIN_ARGS = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
34MESON_C_ARGS = "${MESON_TOOLCHAIN_ARGS} ${CFLAGS}"
35MESON_CPP_ARGS = "${MESON_TOOLCHAIN_ARGS} ${CXXFLAGS}"
36MESON_LINK_ARGS = "${MESON_TOOLCHAIN_ARGS} ${LDFLAGS}"
37
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038EXTRA_OEMESON_append = " ${PACKAGECONFIG_CONFARGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040039
40MESON_CROSS_FILE = ""
41MESON_CROSS_FILE_class-target = "--cross-file ${WORKDIR}/meson.cross"
42MESON_CROSS_FILE_class-nativesdk = "--cross-file ${WORKDIR}/meson.cross"
43
44def meson_array(var, d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045 items = d.getVar(var).split()
46 return repr(items[0] if len(items) == 1 else items)
47
48# Map our ARCH values to what Meson expects:
49# http://mesonbuild.com/Reference-tables.html#cpu-families
50def meson_cpu_family(var, d):
51 import re
52 arch = d.getVar(var)
53 if arch == 'powerpc':
54 return 'ppc'
55 elif arch == 'powerpc64':
56 return 'ppc64'
57 elif arch == 'mipsel':
58 return 'mips'
59 elif re.match(r"i[3-6]86", arch):
60 return "x86"
61 else:
62 return arch
63
64def meson_endian(prefix, d):
65 arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS")
66 sitedata = siteinfo_data_for_machine(arch, os, d)
67 if "endian-little" in sitedata:
68 return "little"
69 elif "endian-big" in sitedata:
70 return "big"
71 else:
72 bb.fatal("Cannot determine endianism for %s-%s" % (arch, os))
Brad Bishop316dfdd2018-06-25 12:45:53 -040073
74addtask write_config before do_configure
75do_write_config[vardeps] += "MESON_C_ARGS MESON_CPP_ARGS MESON_LINK_ARGS CC CXX LD AR NM STRIP READELF"
76do_write_config() {
77 # This needs to be Py to split the args into single-element lists
78 cat >${WORKDIR}/meson.cross <<EOF
79[binaries]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080c = ${@meson_array('CC', d)}
81cpp = ${@meson_array('CXX', d)}
82ar = ${@meson_array('AR', d)}
83nm = ${@meson_array('NM', d)}
84ld = ${@meson_array('LD', d)}
85strip = ${@meson_array('STRIP', d)}
86readelf = ${@meson_array('READELF', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -040087pkgconfig = 'pkg-config'
88
89[properties]
90needs_exe_wrapper = true
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080091c_args = ${@meson_array('MESON_C_ARGS', d)}
92c_link_args = ${@meson_array('MESON_LINK_ARGS', d)}
93cpp_args = ${@meson_array('MESON_CPP_ARGS', d)}
94cpp_link_args = ${@meson_array('MESON_LINK_ARGS', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -040095gtkdoc_exe_wrapper = '${B}/gtkdoc-qemuwrapper'
96
97[host_machine]
98system = '${HOST_OS}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080099cpu_family = '${@meson_cpu_family('HOST_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400100cpu = '${HOST_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800101endian = '${@meson_endian('HOST', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400102
103[target_machine]
104system = '${TARGET_OS}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800105cpu_family = '${@meson_cpu_family('TARGET_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400106cpu = '${TARGET_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800107endian = '${@meson_endian('TARGET', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400108EOF
109}
110
111CONFIGURE_FILES = "meson.build"
112
113meson_do_configure() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800114 # Work around "Meson fails if /tmp is mounted with noexec #2972"
115 mkdir -p "${B}/meson-private/tmp"
116 export TMPDIR="${B}/meson-private/tmp"
117 bbnote Executing meson ${EXTRA_OEMESON}...
Brad Bishop316dfdd2018-06-25 12:45:53 -0400118 if ! meson ${MESONOPTS} "${MESON_SOURCEPATH}" "${B}" ${MESON_CROSS_FILE} ${EXTRA_OEMESON}; then
Brad Bishop316dfdd2018-06-25 12:45:53 -0400119 bbfatal_log meson failed
120 fi
121}
122
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800123override_native_tools() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400124 # Set these so that meson uses the native tools for its build sanity tests,
125 # which require executables to be runnable. The cross file will still
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800126 # override these for the target build.
Brad Bishop316dfdd2018-06-25 12:45:53 -0400127 export CC="${BUILD_CC}"
128 export CXX="${BUILD_CXX}"
129 export LD="${BUILD_LD}"
130 export AR="${BUILD_AR}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800131 # These contain *target* flags but will be used as *native* flags. The
132 # correct native flags will be passed via -Dc_args and so on, unset them so
133 # they don't interfere with tools invoked by Meson (such as g-ir-scanner)
134 unset CPPFLAGS CFLAGS CXXFLAGS LDFLAGS
135}
136
137meson_do_configure_prepend_class-target() {
138 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400139}
140
141meson_do_configure_prepend_class-nativesdk() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800142 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400143}
144
145meson_do_configure_prepend_class-native() {
146 export PKG_CONFIG="pkg-config-native"
147}
148
149do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
150meson_do_compile() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800151 ninja -v ${PARALLEL_MAKE}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400152}
153
154meson_do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800155 DESTDIR='${D}' ninja -v ${PARALLEL_MAKEINST} install
Brad Bishop316dfdd2018-06-25 12:45:53 -0400156}
157
158EXPORT_FUNCTIONS do_configure do_compile do_install