blob: b7383bd2a6b71c6701d604912e81208cb7808241 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "High level language (GLib) binding for D-Bus"
2DESCRIPTION = "GLib bindings for the D-Bus message bus that integrate \
3the D-Bus library with the GLib thread abstraction and main loop."
4HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
5LICENSE = "AFL-2 | GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=cf5b3a2f7083750d504333114e738656 \
7 file://dbus/dbus-glib.h;beginline=7;endline=21;md5=7755c9d7abccd5dbd25a6a974538bb3c"
8SECTION = "base"
9
10DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
11DEPENDS_class-native = "glib-2.0-native dbus-native"
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
14 file://no-examples.patch \
15 file://test-install-makefile.patch \
16"
17SRC_URI[md5sum] = "d7cebf1d69445cbd28b4983392145192"
18SRC_URI[sha256sum] = "7ce4760cf66c69148f6bd6c92feaabb8812dee30846b24cd0f7395c436d7e825"
19
20inherit autotools pkgconfig gettext bash-completion gtk-doc
21
22#default disable regression tests, some unit test code in non testing code
23#PACKAGECONFIG_pn-${PN} = "tests" enable regression tests local.conf
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[tests] = "--enable-tests,,,"
26
27EXTRA_OECONF_class-target = "--with-dbus-binding-tool=${STAGING_BINDIR_NATIVE}/dbus-binding-tool"
28
29PACKAGES += "${PN}-tests"
30
31FILES_${PN} = "${libdir}/lib*${SOLIBS}"
32FILES_${PN}-bash-completion += "${libexecdir}/dbus-bash-completion-helper"
33FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
34FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
35
36RDEPENDS_${PN}-tests += "dbus-x11"
37FILES_${PN}-tests = "${datadir}/${BPN}/tests"
38
39BBCLASSEXTEND = "native"