blob: c9e6081a357cccc8dec88b0f0eeacd4e7869a5ca [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "http://expat.sourceforge.net/"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=5b8620d98e49772d95fc1d291c26aa79"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
10 file://autotools.patch \
11 file://libtool-tag.patch \
12 "
13
14SRC_URI[md5sum] = "ca047ae951b40020ac831c28859161b2"
15SRC_URI[sha256sum] = "17b43c2716d521369f82fc2dc70f359860e90fa440bea65b3b85f0b246ea81f2"
16
17inherit autotools lib_package
18
19do_configure_prepend () {
20 rm -f ${S}/conftools/libtool.m4
21}
22
23BBCLASSEXTEND = "native nativesdk"