blob: 2960811048ebe54debe8d2a948df85378877c640 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-Correctly-install-the-shared-library.patch \
10 "
11
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012PV = "0.11.1+git${SRCPV}"
13SRCREV = "434a40babdde57ab405e9a1085a30e9575ea0c92"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014
15S = "${WORKDIR}/git"
16
17DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
18DEPENDS_append_class-native = " file-replacement-native"
19
20inherit cmake pkgconfig bash-completion distutils3-base
21
22EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
23
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024BBCLASSEXTEND = "native nativesdk"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
27do_install_append_class-native() {
28 create_wrapper ${D}/${bindir}/createrepo_c \
29 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
30}
31
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032do_install_append_class-nativesdk() {
33 create_wrapper ${D}/${bindir}/createrepo_c \
34 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
35 rm -rf ${D}/etc
36}