blob: 93d77797c95f3d10bfbf7ad072b5cf8668f31a27 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
9
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
13"
14
15SRC_URI[md5sum] = "91e106bb34cb097750db7ddc0ba1d8fc"
16SRC_URI[sha256sum] = "7f09183644ed77a156b15346bbad4e89c93543e140add9dab18747e30522591f"
17
18S = "${WORKDIR}/diffstat-${PV}"
19
20inherit autotools gettext ptest
21
22EXTRA_AUTORECONF += "--exclude=aclocal"
23
24LDFLAGS += "${TOOLCHAIN_OPTIONS}"
25
26do_install_ptest() {
27 cp -r ${S}/testing ${D}${PTEST_PATH}
28}