blob: 8c48f4d1b189168c8e1405d24d8bd81a361ac3de [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001Upstream-Status: Pending [from debian]
2Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
3
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004From 77cb4a53c270d5854d3af24f19547bc3de825233 Mon Sep 17 00:00:00 2001
5From: James Cowgill <james410@cowgill.org.uk>
6Date: Mon, 5 Jan 2015 15:16:58 +0000
7Subject: [PATCH 1/3] Ignore differences between mips machine identifiers
8
9Little endian binaries actually use EM_MIPS so you can't tell the endianness
10from the elf machine id. Also, the EM_MIPS_RS3_LE machine is dead anyway (the
11kernel will not load binaries containing it).
12
13Signed-off-by: James Cowgill <james410@cowgill.org.uk>
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014---
15 backends/mips_init.c | 6 +-----
16 1 file changed, 1 insertion(+), 5 deletions(-)
17
18Index: b/backends/mips_init.c
19===================================================================
20--- a/backends/mips_init.c
21+++ b/backends/mips_init.c
22@@ -45,11 +45,7 @@ mips_init (Elf *elf __attribute__ ((unus
23 return NULL;
24
25 /* We handle it. */
26- if (machine == EM_MIPS)
27- eh->name = "MIPS R3000 big-endian";
28- else if (machine == EM_MIPS_RS3_LE)
29- eh->name = "MIPS R3000 little-endian";
30-
31+ eh->name = "MIPS";
32 mips_init_reloc (eh);
33 HOOK (eh, reloc_simple_type);
34 HOOK (eh, return_value_location);